Kategorie: Allgemein

Einfügemodus in VI: Cursor Bewegen durch Pfeiltasten nicht möglich

Wenn man auf einem Linux Server via SSH sitzt, kommt es auch vor, das man evtl. Dateien editieren muss. Sollte nun im VI die CURSOR Belegung nicht funktionieren, gibt es eine kleine aber effektive Methode, dies (wieder) einzuschalten.

Symptom: es erscheinen immer nur die Zeichen A (bei hoch), B (bei runter), C (bei rechts) und D (bei links) im Text.

Abhilfe: (in Vim) den Befehl :set nocompatible eingeben, oder für eine dauerhafte Lösung: in der Shell (in Bash) echo "set nocompatible" > ~/.vimrc eingeben.

Die Datei wird angelegt, wenn nicht vorhanden, oder das Setup wird an das Ende der Datei geklebt.

Somit sollte dies funktionieren.

Filed under: Allgemein

invalid-bs_jmpboot-in-boot-block-000000

An einem meiner Macs habe ich eine 1TB Harddisk, wo so allerhand Krimskrams gespeichert ist.
Aufgeteilt in jeweils zwei gleichgroße Partitionen. Vor kurzem hat mein macOS die zweite nicht mehr erkannt. Ein Blick mit dem Festplattendienstprogramm ergab, das diese Partition nicht mehr mountbar war. Diese Partiton hatte kein Volume mehr, und meldete sich nur mit disk6s2. Ein Versuch, das Volume zu reparieren, scheiterte.

** /dev/disk6s2Invalid BS_jmpBoot in boot block: 000000Reparatur des Volumes abgeschlossen.Boot-Support-Partition nach Beadrf für das Volumen aktualisieren.Fehler: Das Festplatten-Dienstprogramm kann dieses Volume nicht reparieren….

Original Text meiner suche im Web:

„It seems that the GUID for the HFS+ volume is changed from {48465300-0000-11AA-AA11-00306543ECAC} (HFS+) to {EBD0A0A2-B9E5-4433-87C0-68B6B72699C7} (“Microsoft Basic Data”). Windows doesn’t have any trouble mounting it as long as MacDrive is installed, it’s OS X that has the problem.«

Bedeutet nun:

Die Fehlermeldung gibt an, dass die DOS/Windows-Partition ungültig sein muss, da die ersten drei Bytes gelöscht sind. Normalerweise muss eine solche Partition mit dem Byte 0xE9 oder mit der Sequenz 0xEB xx 0x90 beginnen.

Ein Ausweg aus dieser misslichen Lage, bzw. die Lösung, steckt in einem kleinen Programm, welches man hier findet:
Danach einfach diesen Schritten folgen und wie von Geisterhand, ist das Volume wieder vorhanden und kann ganz normal gemountet werden.
Ich sage nur – der Autor »Saved my Day!«
1) Auflisten der Partitionen

andy@MacPRO:/Users/andy/Desktop > ./gpt_surgeon.py list /dev/disk6
Read MBR and GPT from /dev/disk6.

partition 0:     type: EFI System    
name: u'EFI System Partition’   
flags: 0x00000000

partition 1:    
type: Apple HFS+    
name: u'MyDatas’   
flags: 0x00000000

partition 2:    
type: Microsoft Basic Data    
name: u'Apple_HFS_Untitled_2’   
flags: 0x00000000

2) Reparieren der Volumes

andy@MacPRO:/Users/andy/Desktop > ./gpt_surgeon.py repair /dev/disk6

Nun sollte das Volume wieder erscheinen und komplett nutzbar sein.

Filed under: Allgemein